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PREFACE 

NOTICE 

Please read this manual carefully before operating or performing maintenance on 

the instrument. Pay special attention to all danger, warning and caution 
statements. Failure to do so could result in serious injury and/or damage to the 
instrument. Keep manual available at all times. 

 

LAYOUT AND MEANING OF WARNINGS 

All safety instructions found in this operation manual follow this pattern (signal words): 

 

DANGER 

DANGER indicates a hazardous situation which, if not avoided, will result in death or serious 
injury. 

 

WARNING 

WARNING indicates a hazardous situation which, if not avoided, could result in death or 
serious injury. 

 

CAUTION 

CAUTION indicates a hazardous situation which, if not avoided, could result in minor or 
moderate injury. 

 

NOTICE 

NOTICE is used to address practices not related to personal injury.  

NOTICE may also indicate a situation which, if not avoided, may cause damage to 

equipment.  
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GENERAL DESCRIPTION 

The data acquisition software OceanLab 4 is an easy-to-use package for pre-deployment system set-up, 
real-time control of the complete system, real-time data acquisition, post-deployment data download, 

data processing, data visualization, data storing and data export for HYDRO-BIOS instruments. 

When connected to a Hydro-Bios instrument (e.g. MPS / NetProbe), OceanLab 4 will automatically load 

calibration and configuration data from the device and configure its user interface accordingly. The 
following list shows typical use cases for OceanLab. 

UNDERWATER ONLINE OPERATIONS 

Display live measuring data (e.g. pressure, temperature etc.) and control the complete system (e.g. trigger 
sampling). This mode is only possible if data transfer infrastructure is available to the HYDRO-BIOS 

instrument, e.g. the ship on which the instrument is to be deployed has a winch with single- or multi conductor 

cable. 

PREPARING OFFLINE OPERATIONS 

Enter a list of action events and program the instrument to execute this list when deployed later. E.g. some 
instruments offer depth or time base programming. 

POST DEPLOYMENT DATA DOWNLOAD 

Data recorded during offline operations can be transferred to and viewed with OceanLab.  

 

Note: 

Depending on the connected instrument some control elements and / or features described in this 

document may not be available. Not all HYDRO-BIOS instruments support OceanLab. 
 

MINIMUM PC REQUIREMENTS 

 Windows 10 / Windows 11 

 2 GHz processor with graphics acceleration capability (e.g. Intel HD graphics) 

 4 GB RAM 

 100MB free space on hard-disk drive 

 Display 1280 x 1024 pixel 

 1 free USB-port 
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BASIC FEATURES  

CONNECT TO HYDRO-BIOS INSTRUMENT 

 Plug in the data cable supplied with the HYDRO-BIOS instrument. 

 Switch on the instrument if it has a main switch. 
Devices without a main switch will turn on automatically when the cable is plugged in. 

 Press Connect.  

Alternative for training purposes: OceanLab 4 can be started in SIMULATION MODE with no HYDRO-BIOS 

instrument connected. 

 Click File > Simulations. 

 Choose from the available instruments. 

STOP SESSION AND CLOSE FILE 

 Press Stop session.  

Data captured so far can now still be viewed. 

 When done close the open file.  

VIEWING LIVE DATA 

 Connect to HYDRO-BIOS instrument. 

 Choose between different data views: 

o Click View > Time-depending graph 

o Click View > Pressure-depending graph 

o Click View > Table 

 Drag right mouse button to scroll. 

 Drag left mouse button or turn scroll wheel to zoom. 

 Double click left mouse button for default view. 

 Live data is automatically saved on the PC. 

 Right click on a component or sensor to change the appearance of the graph, change decimal 
places etc. 

PREPARING OFFLINE OPERATIONS 

 Connect to Hydro-Bios instrument. 

 View > Controlling mode. 

 Program / activate the instrument using the buttons that appear in the left side component 

window. Refer to the instrument manual and the live help in OceanLab for more details. 

RETRIEVING FILES FROM HYDRO-BIOS INSTRUMENT 

Offline files are generated on the Hydro-Bios instrument itself. They have to be transferred to the PC for 

viewing with OceanLab. 

 Connect to Hydro-Bios instrument. 

 Click View > Controlling mode. 

 Click Memory on the left. 
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 Follow the instructions presented in this menu. 

VIEWING PREVIOUSLY STORED FILES 

 Click Open file.  

 Select the desired file. 

 Numbers on the left show sensor values at the location of the cursor line. 

 Set the cursor line using a left click. 

 Step the cursor line using the cursor keys on the keyboard. 

CHANGING CALIBRATION PARAMETERS 

 Connect to Hydro-Bios instrument. 

 Click View > Controlling mode. 

 Click on the sensor to display its calibration coefficients (e.g. pressure). 
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ADVANCED FEATURES 

HEADERS AND COMMENTS 

When starting a session OceanLab 4 automatically creates a header information comment which includes 
mission details. As template for this comment OceanLab 4 uses the file “header.txt” (located inside the 
OceanLab 4 application data directory). Modify this text file and OceanLab will generate a different default 

comment. 

Inside the GRAPHS window a blue box at the bottom marks the position of this header information. Click 
it to modify the contents on a per mission basis. The header information will be incorporated into the 
export files that can be created inside the VIEWER module of OceanLab 4. 

Additional comments can be created at any time (e.g. to add additional information of interest to a specific 

moment) by simply pressing the space bar. Inside the time-depending GRAPHS window yellow boxes mark 

the positions of the LOGFILE EDITOR comments. The LOGFILE EDITOR comments will be incorporated into 

the export files that can be created inside the VIEWER module of OceanLab 4. 

As template for the additional comments OceanLab 4 uses the file “comments.txt” (located inside the 

OceanLab 4 application data directory) which can be individually configured according to the needs of the 
user. 

Note: OceanLab 4 automatically starts a new session (and thus creates new data and comments files) when 

modifications are made inside the CONTROLLING dialogs of the CONTROLLING MODE. 

EXPORTING DATA 

The data files created by OceanLab 4 are stored at the PC in binary format. Export data in ASCII-format for 
use with current word-processing, spreadsheet and data base software. 

 Click File > Export. 

The LOGFILE EDITOR comments will be incorporated into the export files. 

CORRECTING CALIBRATION VALUES POST DEPLOYMENT 

If a mission was carried out with wrong or outdated calibration values by mistake, these can be adjusted 

after the fact. For example, the user could have forgotten to perform a field calibration of an oxygen sensor 
before deployment. They could then perform the calibration (shortly) after the mission and have OceanLab 
re-calculate the sensor values. 

 Open a file. 

 Click View > Controlling mode. 

 Click on the sensor of interest. 

 Correct the calibration coefficients. 

 Click Send to sensor. 

 The physical values will now be recalculated. 

 When closing the file Oceanlab will ask if the changes are to be saved in the file or not. 

INCLUDING LOCATION (GPS) DATA 

The integration of GPS data is made at the PC directly inside the data acquisition software OceanLab 4. 

The GPS data must be provided via a virtual serial COM-port.  

This is accomplished by either: 
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a) Connecting an external GPS receiver to the PC (via USB port). In this case the driver of the GPS 

receiver creates a virtual serial COM-port which is accessible by OceanLab 4. 

b) On board of some research vessels the GPS data are available at serial COM-ports (at a junction 
box in the dry lab). In this case use an USB-adaptor to link the port to your PC.  

c) Some ships distribute the GPS data via the ships network. In this case contact the ships network 

administrator to evaluate if the GPS data can be re-directed to a virtual serial COM-port at your PC.  

OceanLab 4 can handle GPS data according to NMEA 0183 provided that the GPS receiver delivers the 
$GPRMC sentence (Recommended Minimum Sentence). 

Note: 

The GPS data can only be merged with OcenLab data files created in online mode (with communication 

between PC and instrument during the operation). 
Therefore always start the GPS module and verify the GPS status before starting the communication 
between the PC and the HYDRO-BIOS instrument! 

 Click Tools > GPS > Comport configuration. 

Typical values: 4800 or 38400 baud, 8 data bits, 1 stop bit, no parity and no handshake.  

 Click Tools > GPS > Connect. 

 Tools > GPS > Display GPS-window. 
 

The status of the GPS data is indicated by different background colouring of the GPS data window and the 

top right GPS LED: 

Red ● No data at serial COM-port.  

GPS receiver is switched off or connected to wrong COM-port. 

Orange ● Bad data at serial COM-port. 
Incorrect configuration of COM-port. 

GPS receiver does not provide $GPRMC sentence. 
Wrong instrument connected to COM-port. 

Yellow ● GPS data with poor quality detected. 

The GPS receiver does not have enough satellites in sight. > Reposition the GPS 
receiver. 

Green LED ●  

(gray GPS window) 

Good Quality GPS data.  

GPS module is automatically recording data.  

 

There is no need to actively start the recording of GPS data. The GPS module automatically records the 

GPS data into a disk file when detecting GPS data in good quality. 

The merging of GPS data and the OceanLab 4 data files is automatically made once the file is reopened. 

 Close the session. 

 Reopen the file. 

The location data can now be seen in table view as well as in exported data. 

Make sure that you always copy the full set of three data files (extensions .hbl .hbc .hbg) in case you want 
to transfer the data files to another PC. 

SERIAL PRESSURE OUT 

This function outputs pressure values from the HYDRO-BIOS instrument via the selected serial COM-port 

in ASCII format. Output is made in the style of NMEA 0183. 
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Example String that is output over serial: $PHBIP,73.12 <CR> <LF> 

 Click Tools > Serial pressure out > Configure ports. 

The standard configuration employs a baud rate of 115200. According to the NMEA 0183 standard the 
interface uses 8 data bits, 1 stop bit, no parity and no handshake. 

To ease the selection of the correct COM-port it is recommended to always start communication with the 

HYDRO-BIOS instrument before selecting the SERIAL PRESSURE OUT interface. 

Note: 
The selected COM-port will not be occupied by the SERIAL PRESSURE OUT until a successful 
communication with a HYDRO-BIOS instrument has been established. This leads to the fact that while 
executing the CONNECTING process (see chapter 5. COMMUNICATION / CONNECTING) OceanLab 4 may 

send data other than those specified above at a different baud rate.  

Enable the SERIAL PRESSURE OUT transmission by activating the tick box “On”. 

The status of the SERIAL PRESSURE OUT module is indicated in the upper right of the MAIN window: 

Green ● OK. Pressure data is being sent. 

Red ● Error (e.g. the selected COM-port is occupied by a HYDRO-BIOS instrument). 

Grey ●  OFF 

DIAGNOSTICS FUNCTIONS 

The three rightmost LEDs at the top indicate the communication state of OceanLab 4: 

White LED ● OceanLab is sending commands to the HYDRO-BIOS instrument (Tx). 

Blue LED ● OceanLab is receiving data from the HYDRO-BIOS instrument (Rx). 

Yellow LED ●  An action device (e.g. motor) inside the HYDRO-BIOS instrument is active. 

 


